KL Exchange Connection Alert

Incident Report for GB Network Solutions

Resolved

This incident has been resolved.
Posted Oct 27, 2025 - 22:24 GMT+08:00

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 27, 2025 - 21:57 GMT+08:00

Identified

We have detected an issue on our KL Exchange connection. Our engineers are on-site investigating. We will provide updates as soon as more information is available.
Posted Oct 27, 2025 - 21:49 GMT+08:00